We are currently performing validation steps on the performed changes.
Posted Aug 10, 2026 - 22:12 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 10, 2026 - 22:05 EDT
Scheduled
We will be performing a minor update to our hosting infrastructure's network configuration. This update period is brief, but may result in degraded response times while performing certain functions using the FusionPrep Tablet Clients.
Posted Aug 10, 2026 - 22:04 EDT
This scheduled maintenance affected: FusionPrep iPad Application, FusionPrep Control Panel and FusionPrep Services (API).